Android - " Разбор данных для Android- 21 не удалось "

? warbi @ | Original: StackOverFlow
---

Если бы следующую ошибку в Eclipse, после установки Android 5.0 ( SDK 21 )

" Загрузка данных для Android 5.0 " столкнулся с проблемой .

Разбор данных для Android- 21 не удалось   поддерживается major.minor версия 51.0

---

Top 5 ответ

1warbi @

Попробуйте установить JDK 1.8 и перезагрузите Eclipse.

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

2Amit P @

Сначала я был сталкиваются с той же проблемы. Я повышен до JDK1.7 . Тем не менее выдавать сохраняются. Это связано с тем, что некоторое время Eclipse, takees SDK по умолчанию как 1,6 . Для решения этой проблемы:

Change the environmental path to point 1.7/1.8 Open Eclipse and goto windows tab-> preference Goto Java->complier and set Compiler compliance level to 1.7 and press apply. Then Goto Installed JRE Section. check if the installed jdk is listed and selected in the list. If not listed give the manual path using search. then select the jdk version and remove other versions in the list. in installed JRE go to execution environment and select the intended java se version and check it in compatible section Presss ok and restart Eclipse.

Это должно решить проблему.