Android Студия Gradle вопрос обновить до версии 0.5.0 - Gradle Миграция от 0,8 до 0,9 - Также Android Студия перейти на 0.8.1

? Cedric Simon @ | Original: StackOverFlow
---

После обновления говорится в сообщении :

Failed to refresh Gradle project 'XXX'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Такой же вопрос после обновления до Android Студия до версии > = 0.8.0

---

Top 5 ответ

1Cedric Simon @

Чтобы исправить это, откройте файл называется build.gradle в корне проекта, а также изменить Gradle версии есть до 0,9. + .

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Для повторяться для каждого проекта; (

Если вы затем получили сообщение " Не удается загрузить класс org.gradle.api.artifacts.result.ResolvedComponentResult " .

Перейти к тебе project_folder/gradle/wrapper каталог и редактировать Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. файл измененииdistributionUrl в

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

После обновления до версии 0.8.1 ( полной загрузки и копирования SDK папки в ), должен был иметь новую версию Gradle установленной на IDE (с помощью" Исправить это " связать пару раз : S), и необходимости модифицировать в разделе " Android" в Gradle файла в папке проекта с 19,0 до 19,1, как показано ниже:     buildscript {         репозитории {             mavenCentral ()         }         зависимости {             ClassPath ' com.android.tools.build:gradle:0.12.+ "         }     }     применять плагин : " андроид "

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 19
    buildToolsVersion '19.1.0'

    defaultConfig {
        minSdkVersion 7
        targetSdkVersion 19
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:19.1.+'
    compile 'com.android.support:support-v4:19.1.0'
}
2Gabriele Mariotti @

Android Студия 0.5.0 требуется Gradle -Plugin 0.9.0

Gradle - плагин 0.9.0 работает с Gradle 1,10 или Gradle 1,11

Измените сценарий build.gradle как это было предложено Седрик .

Существуетсвязь между Gradle - плагина и Gradle версии. например

com.android.tools.build:gradle:0.6.+   -> gradle 1.8
com.android.tools.build:gradle:0.7.+   -> gradle 1.9
com.android.tools.build:gradle:0.8.+   -> gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+   -> gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+  -> gradle 2.1
com.android.tools.build:gradle:0.14.+  -> gradle 2.1
com.android.tools.build:gradle:1.0.+   -> gradle 2.2.1

Вы можете найти Gradle версию, используемую в вашем проекте в файле gradle/wrapper/gradle-wrapper.properties

Также естьсвязь между Gradle - плагина и версии IDE. Обновлено до 08/12/2014 :

Android Studio 0.3.x  -> gradle-plugin 0.6
Android Studio 0.4.x  -> gradle-plugin 0.7
Android Studio 0.4.3+ -> gradle-plugin 0.8
Android Studio 0.5.x  -> gradle-plugin 0.9
Android Studio 0.5.8  -> gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9  -> gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x  -> gradle-plugin 0.11.+
Android Studio 0.8.x  -> gradle-plugin 0.12.+
Android Studio 0.8.11+  -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x  -> gradle-plugin 0.14.+
Android Studio 1.0.0  -> gradle-plugin 1.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

Для обновляемые новости вы можете проверить по этой ссылке: http://tools.android.com/recent

Если вы измените вашу версию плагина, проверьте совместимость, а затем нажмите кнопку Синхронизировать проект со своим Gradle files.It будет скачать новую версию плагина, если вам это нужно.

3pierre renoir @

хм, я получаю эту ошибку, когда я пытаюсь добавить эту зависимость .

Ошибка: ( 22 ) задачаоценки проекта ': приложение .

Не удалось найти метод классам () для аргументов [ com.android.tools.build:gradle:0.9.+ ] по проекту " : приложение .

Хорошо решить ее . Эта линия должна быть частью build.gradle "в корне проекта ", как сказано выше, но я не узнал . Обновление сборки инструменты, чтобы 19,03 вставлен это автоматически.

4lucidbrot @

Я была такая же ошибка, но уже

classpath 'com.android.tools.build:gradle:0.9.+'

установлены таким образом, как это было предложено Седрик Саймон. Благодаря комментарий mattblang, я попытался изменить его на 0.9.0 и перезапустили его

для тех, кто не знает, гдекнопка обновления, посмотрите ниже:

Android Студия Gradle вопрос обновить до версии 0.5.0 - Gradle Миграция от 0,8 до 0,9 - Также Android Студия перейти на 0.8.1

Потом я попробовал то, что происходит, когда я изменить его обратно до 0,9. + И обновите снова ... и он все еще работает .

Так что я предположить, только нажавкнопку обновления хватило бы .

5codercat @

Самый простой Android проект имеет следующую build.gradle :

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.0'
    }
}

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"
}

Есть 3 основных направления на данный файл Android сборки:

http://tools.android.com/tech-docs/new-build-system/user-guide