Затмение ADT : Название проекта " appcompat_v7 " создаются после создания каждого нового проекта

? uLYsseus @ | Original: StackOverFlow
---

Ну, я хочу, чтобы выделить это и свести все это в этой теме, какостальная часть нитей не было заключено ответ, поэтому перед пропуская их здесь являются темы о котором я говорила :

http://stackoverflow.com/questions/22203862/adt-doesnt-create-default-hello-world-but-command-line-does

http://stackoverflow.com/questions/22250633/eclipse-behaving-differently-while-creating-new-project-activity

ADT ведет себянемного странно, так как последние несколько дней. Я держу мой SDK постоянно обновляется, так что я часто Запустите менеджер SDK и скачать все обновления . в последнее время я заметил, что если я создаю новый Android App проект он не создавая MainActivity умолчанию, даже если я проверю, что коробка, она не создает деятельность под SRC и больше меня раздражать, я не был в состоянии реорганизовать ничего, так что я понял, что я должен был обновить Eclipse, как после прочтения нескольких должностей, но теперь, когда я создаю каждый новый проект создает раздражающий appcompat_v7 проект с каждым проектом, скажем, создать два новых проекта, которые он создает appcompat_v7_2 .... это сводит меня с ума, и новая библиотека проектпроект appcompat_v7 . Это становится раздражает и не знаю, что происходит здесь !!!! Что я должен сделать ... пожалуйста спасти меня ! Спасибо заранее ....Скриншот раздражать у парней тоже ... :)

Затмение ADT : Название проекта " appcompat_v7 " создаются после создания каждого нового проекта

*************** Современной альтернативой, а нерешение ***********************

По состоянию на 12/5/2014 с ADT 23.0.2 я не вижу эту проблему больше.

I have waited for an acceptable solution on this issue (as of now there is none), but one of the SO members directed me to this post https://code.google.com/p/android/issues/detail?id=66975 . What I am doing is described in one of the solutions below, but for people who have come to this post, the alternative is to delete that ugly project(if you have more than one) which has been created and add up this one(appcompat_v7) as a library. So if you create another project and appcomat_v7_2...comes up delete that and point your project to the appcompat_v7, do the same for other projects too. This is not recommended for some reason though, but it worked well for me till now without issues. If anyone hits up with a solution please post it here. **************** Современной альтернативой, а нерешение *****************************

---

Top 5 ответ

1user3033613 @

Папка appcompat_v7 не получает создан, если я использую

minSdkVersion="14"
2shap4th @

Похоже, этоошибка затмение . Что нужно сделать, это зайти в свойства вАндроида проекта и в разделе Android. Добавить в библиотеку appcompat_v7 и снимите appcompat_v_7_2 (дубликат ). Затем вы можете удалить appcompat_v7_2 в качестве проекта Eclipse. Исправлены все ошибки .

Простообходной путь .

3GPrimola @

AppCompat проектбиблиотеки для поддержки старых версий Android. Библиотека поддержки было введено Google в последнее время - я не знаю, в какую версию Android. Нодело в том, этот проект создается только при создании Android проект, чтобы пересечь Android платформ. Я имею в виду, когда вы выбираете старый мин API, например, API 8 ( Froyo ), но целевые недавно версии, ваш проект должен иметь поддержку библиотеки . Во всяком случае,создание appcompat_v7 проекта является какой-то вопрос, который должен быть лучше настроены сопровождающим плагина Eclipse. Однако вы можете элегантно перевернуть эту проблему путем охвата новые API-интерфейсы и в том числе в путь сборкибиблиотеки поддержки . Это более элегантно, чем другие, потому что это лучше сосредоточиться только на одном андроид версии при создании приложения, и когда это будет сделано, у вас есть подлинный версию своего приложения, которые можно использовать в качестве формы для поддержки других версий, либо старшего возраста или newers .