Jar несоответствие ! Исправьте зависимости при использовании appcompat_v7 и Facebook SDK .

? KousiK @ | Original: StackOverFlow
---

Я использую appcompat_v7 библиотека и facebook SDK в моем проекте, и обабиблиотеке и Android -поддержка - v4.jar.If удалить любой из банкисоответствующих библиотека не работает и имеющие обе банки, не допускается.

Что я должен делать? Пожалуйста, помогите мне ...

---

Top 5 ответ

1Raghunandan @

Конфликт из-за разных версий банку.

Убедитесь, что у вас есть библиотека поддержки обновлений из Android Manager SDK

Копировать android-support-v4.jar для библиотеками обеих проектов. Банку можно найти @

android-sdk/extras/android/support/v4/andorid-support-v4.jar

Очистите и построить свой проект

2milapTank @

удалить Android- Опорно- v4.jar от Facebook SDK и добавить Android- Опорно- v4.jar как свойства facebookSDK внешний банке - > Java Build Path - > Библиотеки -> добавить внешний банку ( я имел удалить эту проблему, как это)

3user2678995 @

Попробуйте удалить библиотеку зависимостей и от appcompat_v7 и вашего проекта. Для этого надо построить путь = > Настроить Build Path . Затем выберите библиотеку зависимостей и нажмите на Удалить . Добавить библиотеку поддержки по Android Tools => добавить библиотеку поддержки. Сделайте это для обоих projects.Then вы хорошо идти

4Safdar Akrami @

Его очень просто

Просто щелкните правой кнопкой мыши на вашем проекте, а также на проект библиотеки > андроид инструментов > Добавить библиотекой поддержки .

Это позволит обновить вашу библиотеку поддержки дляпоследней, которая решает эту проблему.

5Rahul Mandaliya @

Этот вопрос задают много раз, пока все это запуск Android развитие в стадии обучения. Я думаю, что каждый человек имеет ту же среду Android, но они настроить разному в зависимости от проектов.

У меня была такая же проблема при создании нового проекта каждый раз, и я нашел решение на ниже. Я добавил библиотеки appcompat_v7 в проект и удалить банку android-support-v4.jar от Lib папки моего нового проекта и будет мигать ERROR не было. Добавить appcompt_v7 проект библиотеки  Jar несоответствие ! Исправьте зависимости при использовании appcompat_v7 и Facebook SDK .

Удалить Android- Опорно- v4.jar из папки Lib проекта  Jar несоответствие ! Исправьте зависимости при использовании appcompat_v7 и Facebook SDK .

Ничего себе ошибка пропала  Jar несоответствие ! Исправьте зависимости при использовании appcompat_v7 и Facebook SDK .