Ошибка: Android SDK требуется Android Developer версии Toolkit 22.6.1 или выше

? TheLittleNaruto @ | Original: StackOverFlow
---

Я установил ADT версии 22.6.1 уже 2 дней назад. Это было прекрасно работать . Внезапно, когда я открываю затмение сегодня, он продолжает показывать мне следующую ошибку:

Это Android SDK требуется Android Developer Toolkit версии 22.6.1 или выше . Текущая версия 22.2.1.v201309180102-833290 . Пожалуйста, обновите ADT до последней версии .

Вот скриншот Android SDK Manager, моего затмения :  Ошибка: Android SDK требуется Android Developer версии Toolkit 22.6.1 или выше

Я попытался с следующим шагам, чтобы решить мою проблему, как описано в этом https://code.google.com/p/android/issues/detail?id=67325

Help | Install new software Select the ADT update site (there are two, one with http:// and one with https://. If one doesn't work, try the other. Select the developer tools section and press next. You should see a dialog that says This software is already installed, an update will be performed instead. Clicking OK will lead to 22.6.1 being installed.

Но, к сожалению, она не работает для меня.

Вотскриншот Я прилагаю который показывает ошибку я получаю при обновлении инструментов.

Ошибка: Android SDK требуется Android Developer версии Toolkit 22.6.1 или выше

Как я могу избавиться от него ?

---

Top 5 ответ

1X-ELECTRON @

Просто удалите существующий ADT и установить новую версию ADT.generally это проблемы происходит      при обновлении SDK, используя ссылку ниже .

https://dl-ssl.google.com/android/eclipse/
2Lalit @

Вчера я решил эту проблему.

Следуйте инструкциям : Помощь -> Установить новое программное обеспечение - > Добавить -> ( Дайте любое имя предположим, NewUpdate ) -> добавить URL: https://dl-ssl.google.com/eclipse/plugin/4.2 -> OK

Теперь она будет список доступных обновлений, которые в идеале должны быть ADT 20.xx

Выберите элементы списка Пусть это будет установлено. Затмение будет перезапущен и его сделали .

Я надеюсь, что это будет полезно для вас :)

3blue @

ADT Bundle на developer.android.com мне кажется, как устаревшие .

Я установил ту же самую проблему с http://eclipse.org/downloads/ (Java EE был мой выбор, но вы можете выбрать аромат ) и http://developer.android.com/sdk/installing/installing-adt.html

4Rick Falck @

В настоящее время я Затмение и ADT установлены в том же каталоге,

F:eclipse
    eclipse
    sdk

Я скачал и установил последнюю ADT для

C:UsersRickAppDataLocalAndroidandroid-sdk

Затем я скопировал содержимоеC:UsersRickAppDataLocalAndroidandroid-sdk в папку F:eclipsesdk, и пусть он объединит все папки и переписать все.

Теперь у меня есть 22.6.1, и я не придется повторно скачать все платформы вещи снова .

5Faruk Toptas @

Я использую OSX и сталкиваются с проблемой в течение 2 дней . Я решил эту проблему, выполнив следующие действия :

-Скачать ADT Bundle от https://developer.android.com/sdk/index.html -Help -> Установить новое программное обеспечение -Write Https://dl-ssl.google.com/android/eclipse/ затем установить инструменты разработчика -Restart Затмение и поднял ошибку ниже:

Android SDK content Loader has encountered a problem.parseSdkContent failed
java.lang.NullPointeException

-Delete .android Папки в профиле пользователя. Перезапуск затмение

Никакие ошибки и 22.6.1 не установлен .