Как я могу создать новый проект без appcompat_v7

? Ankit Kumar @ | Original: StackOverFlow
---

Я не могу получить, почему appcompat_v7 создается автоматически ... найти его очень раздражает .. пожалуйста кто-нибудь помочь, чтобы избавиться от этой проблемы. Я попытался создать новый проект и найти, как это для каждого вновь созданного проекта .

---

Top 5 ответ

1taxo @

При создании нового Android Project снимите флажок напротив " Создать активности " . Делая это, Eclipse не будет автоматически импортировать проект библиотеки " appcompat_v7 " . Тогда вы вручную должны создать основную деятельность . Будьте осторожны, что импортирует вы используете, если у вас есть такие вещи, как Fragment или ActionBar .

http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a Очень полезно .

Надеюсь, что это помогает! :)

2Ishara Amarasekera @

Когда вы создаете приложение, дают API 14 : Android 4.0 или верхний вариант в качестве минимальной версии SDK.

3svg @

Причина, почему Затмение делает это, потому что естьмного фрагментации в различных производителей и версий Android итот же отражает вAPI слишком .. !! Таким образом, в целях сохранить все, что происходит гладко Android предлагает добавить внешних библиотек в проект и Eclipse, пребывает вто же самое.

Вы можете избавиться от него, если вы создали, цель и составить уровня, как то же самое, используя минимальное SDK выше 7 будет также сделать трюк.

ссылаться  http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a