" AAPT " Ошибка ввода-вывода ошибки = 2, Нет такого файла или каталога " почему я не могу строить свою Gradle на Дженкинс ?

? Neifen @ | Original: StackOverFlow
---

У меня есть небольшая проблема .

Проблема: Я пытаюсь построить Gradle моей Android проекта на Дженкинса, и теперь я стою на этой проблеме я не могу решить . В здании у меня есть сообщение об ошибке:

:Client:mergeDebugResources
/var/lib/jenkins/workspace/LMA-Client/Client/build/exploded-aar/com.google.android.gms/play-services/3.1.59/res/drawable-hdpi/common_signin_btn_text_focus_light.9.png: 
Error: Cannot run program "/opt/android-sdk/build-tools/19.0.1/aapt": java.io.IOException: error=2, No such file or directory
:Client:mergeDebugResources FAILED

Вы можете себе представить, что это AAPT ... да его там, и PNG ... его там тоже, так чтоошибка должна быть где-то в другом месте.

Решение ? Теперь я гугле 1-2 часа вокруг, кататься на этой большой сайт, и что я нашел то, что, если Дженкинс работает на 64 -битной системе, мне нужно, чтобы установить ia32 - LIBS . Как, что:

sudo apt-get install ia32-libs

Теперь я попытался это, и я не мог установить его :

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch

так что я попытался установить " ia32 - библиотеками - мультиархитектурная ", но опять же :

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libgphoto2-2:i386 but it is not going to be installed
                            Depends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

в конце концов так что, наконец Im стоя здесь и спрашивают меня : это действительнорешение? И почему я должен установить эту вещь ? И как это сделать? Поэтому, пожалуйста, помогите мне, я думаю, что я не далеко от ответа . спасибо

---

Top 5 ответ

1robd @

Я имел следующую подобную ошибку на Ubuntu 13.10 :

Cannot run program "/usr/local/android-sdk-linux/build-tools/19.0.3/aapt": error=2, No such file or directory

И http://stackoverflow.com/a/18930424/514483 установил ее для меня :

Чтобы получить AAPT работу (это надела проблемы с AVD, а ) просто установить эти два пакета :

sudo apt-get install lib32stdc++6 lib32z1