Fix Gradle проблему несовместимости при импорте Android типовой проект

? Sebastien @ | Original: StackOverFlow
---

Android -студио ( 0.5.3 ) сводит меня с ума.

Я никогда не имел каких-либо серьезных проблем с Eclipse, и ADT. Android Студия другая история : я не был в состоянии получить один проект, чтобы правильно построить с ним.

Таким образом, я пытаюсь импортировать пример проекта Android ( который я полагаю правильность настройки Gradle и должны готовы быть импортированы ) :

C:pathToMyAndroidSDKsdksamplesandroid-19contentStorageProvider

Первая ошибка, я получаю этоследующим образом:

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of Gradle. Please use version 1.10.
Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
Fix Gradle wrapper and re-import project Gradle settings

Итак, я могу скачать Gradle 1,10, и изменить проект установки Gradle, так что она использует этот локальный распределение Gradle вместо оболочки по умолчанию Gradle ( который, кажется, должны быть включены в проект образца) .

Я получаюразличные ошибки на этот раз :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Я не знаю, Gradle достаточно, чтобы перенестиконфигурацию себя, и я действительно не хочу.

Как я могу просто использовать Gradle обертку без gettting вызвал использовать Gradle 1,10 ( который не совместим с проектом) ? Любое другое решение также будет приветствоваться .

Примечание: Я пытался с другими проектами образца в Android- 19 папки, только чтобы получить те же самые ошибки .

EDIT:

Я повезло больше, пытаясь построить под Linux с командной строкой ( gradlew build ).

Телосложение удалось, независимо от того, что я установить в build.gradle :

classpath 'com.android.tools.build:gradle:0.9.+'

or

classpath 'com.android.tools.build:gradle:0.8.+' #(the original configuration of the sample project)

Так моя проблема, вероятно, вызвано ошибками в Android Studio.

---

Top 5 ответ

1Gabriele Mariotti @

Не зная Gradle, это довольно сложно, чтобы решить эту проблему.

В то же время Android Студияальфа-релиз, так что он может быстро меняться, и каждая версия может ввести несовместимые изменения

Вотпервый документ, чтобы прочитать о проекте с Android Студия:  https://developer.android.com/sdk/installing/studio-build.html

Вы используете в качестве 0.5.3, так что вы должны использовать Gradle 1,10 / 1,11 иGradle 0.9.x плагин

Это означает, что в вашем скрипте build.gradle вы должны использовать :

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Может быть, в вашем файле у вас есть 0.8.3 .

Также вы должны использовать Gradle 1,10 / 1,11 . Вы должны иметь папку * project_folder / Gradle / оболочка *, где есть файл gradle-wrapper.properties .

Здесь вы должны изменить ключ distributionUrl использовать один из этих версии :

distributionUrl = HTTP : //services.gradle.org/distributions/gradle-1.10-all.zip

Android Studio - Gradle - Gradle плагин есть какое-то отношение :

http://stackoverflow.com/questions/22252956/android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0/22256954#22256954

Может быть ваш скрипт Gradle может иметь и другие проблемы, возникающие после этих изменений.