Затмение не можете найти android.support.v4.widget.SwipeRefreshLayout

? Katedral Pillon @ | Original: StackOverFlow
---

Даже после нажатия на Добавить библиотекой поддержки и выбрав вариант 19, затмение сих пор не могу найти android.support.v4.widget.SwipeRefreshLayout . Кто-нибудь знает, как получить эту работу ? Я использую

<uses-sdk
android:minSdkVersion="11"
android:targetSdkVersion="19" />

Я работаю на Маке Маверикс компьютер с Юноны .

обновление: раздел импорта

import java.util.Observer;

import android.content.Intent;
import android.os.Bundle;
import android.support.v4.app.DialogFragment;
import android.util.Log;
import android.view.View;
import android.widget.AdapterView;
import android.widget.AdapterView.OnItemClickListener;
import android.widget.ListView;
import android.widget.TextView;
import android.support.v4.widget.SwipeRefreshLayout;//red underline

Update

Кстати, я не знаю, если это имеет значение: этоAppengine связи Android Project, который я строю, используя Google затмения -плагин

Update 3:

Это выглядит как Android Поддержка Библиотека 19.1.0 не доступны через SDK Manager. Как еще я мог бы ее получить?

---

Top 5 ответ

1tehnolog @

Я была такая же проблема со старым проектом. Но когда я создаю новый проект, Eclipse можно найти данный импорт.

2user936580 @

Это выглядит так, как будто вы не имеете Android- Опорно- v4.jar в путь сборки Java. Добавьте его от андроида -поддержка - v7- AppCompat .

3Katedral Pillon @

Вот и получается,библиотека находится в следующей папке

/android-sdk-macosx/extras/android/m2repository/com/android/support/support-v4/19.1.0

В отличие от обычного

/android-sdk-macosx/extras/android/support

Кроме того, я должен был перезапустить затмения и перейти к Android SDK Manager снова и снова и снова, покаверсия 19.1.0 не появляется.

Я надеюсь, что это экономит кого-то еще некоторые проблемы .

4Lee HyunSoo @

Обновление SDK менеджер для Android Библиотека Поддержка 19.1.0 . Но когда вы используете Android Tools> Add поддержки библиотек, затмение обновления Android библиотека поддержки до 19,0 . Я думаю, что этоошибка . Копировать Android Поддержка Библиотека 19.1.0 для библиотеками папку вручную.

5birdy @

Этопроблема с обновлением поддержки библиотеки из затмения : https://code.google.com/p/android/issues/detail?id=67991

Просто обновите его запускать Диспетчер Android SDK вручную и добавить новый v4 LIB для вашего проекта .