Проект новое применение Android не можете создать чистую активность

? Nikolius @ | Original: StackOverFlow
---

Я еще новичок в андроид развития и просто решил узнать . Однако я сталкиваются некоторые проблемы, которые сводят меня с ума эта пара часов .. я просто хочу, чтобы создать новый проект с этой установкой

Проект новое применение Android не можете создать чистую активность

Проблема в том, я не могу создать новый пустой деятельность с ним, он говорит, что требуется создать цель API версии по меньшей мере 14, атекущая версия 8

Проект новое применение Android не можете создать чистую активность

Я просто хочу, чтобы попытаться построить приложение, которое поддерживает от Android 2.2 ( API 8 ) и далее .. является то, что просто не возможно прямо сейчас, чтобы создатьAndroid 2.2 совместимые приложения с пустого шаблона деятельности ? поэтому для того, чтобы использовать пустой шаблон активности я должен использовать Android 4.0 ( API 14 ) ? это правильно?

---

Top 5 ответ

1Shivansh Saxena @

Перейдите по этой ссылке, я думаю, что этолучшее место, чтобы узнать андроида от основного   https://developer.android.com/training/basics/firstapp/index.html?hl=it

2ojonugwa ochalifu @

Изменение минимально необходимый SDK для 9 и целевую SDK до 18

3user3439968 @

Это новая функция ADT 22.6.2

Даже в "None " тема ADT ( 22.6.2 ) создать «Фрагмент макета "

Существует четыре способа :

Попробуйте изменить " Target" и " Compile " для API 14 или выше. Но для этого нужно затем удалить все записи из " Фрагмент макеты "

Снимите " Создать активности " флажок, и создать активность вручную. Хорошо практическими рекомендациями :  http://stackoverflow.com/questions/2337874/best-way-to-add-activity-to-an-android-project-in-eclipse

Понижение в 22.3.0 например

Попробуйте изменить шаблоны. В ссылкам ниже вы найдете HOWTO.

Я использую третий путь для моих приложений с API, более низких 14. В разных каталогах я установил 22.3.0 и 22.6.2

Там в 22.6.2 какой-то другой ошибки с пустыми файлов и проблем с AVD . Новая версия ADT действительно глючит ...

Смотрите также этот ссылкам:

http://stackoverflow.com/questions/22289164/adt-blank-activity-created-with-fragment-activity

http://stackoverflow.com/questions/22278479/eclipse-doesnt-generate-mainactivity-java-activity-main-xml

и искать, да )

http://stackoverflow.com/search?q=adt+22.6

Добавлено несколько новых способов .

Как я использую его теперь :

You can create project in 22.3.0 or lower. Then open it in 22.6 or greater. You can create project in 22.3.0 or lower and leave it blank. Then in 22.6 or greater you can use this blank project as template. Just copy this template-project and past it with new name as you new-project in Eclipse workspase.

Enjoy! )

4user3459475 @

это будет сложно потенциала для такой версии, вы можете оставить вам минимальный SDK на Yoru желаемого . Тем не менее вы должны увеличить макс, если Ваша минимум что-нибудь менее 15 ,ADK сейчас строит дополнительный папку ( новый материал ) По правде говоряновая версия ADT раздражает, я просто начала и теперь вы будете видеть, что они имеют исполнение использование фрагментов .

5Harison Silva @

Я понял, что мы можем использовать пустые активность, а не пустой деятельности . Теперь в пустой создается фрагмент, расположение и R.java обновляется .