Не удается запустить проект Eclipse, - не может найти базу данных API

? F1sher @ | Original: StackOverFlow
---

Мой код компилируется . Там нет ошибок в коде . Я скачал полный SDK. На счете я получаю эту ошибку :

Can't find API database; API check not performed        

И это в Откуда : линии 1, тип Android Lint проблема.

Я понятия не имею, что случилось .

---

Top 5 ответ

1F1sher @

Я зафиксировал его . В манифесте я имел в использования, SDK minSdkVersion указанного но у меня не было targetSdkVersion . После добавления параметра targetSdkVersion это составлено и побежал.

2BartoszK @

Я решил его по-разному . В манифесте я имел :

<uses-sdk
    android:minSdkVersion="9"
    android:targetSdkVersion="19" />

Проблема была в том, что после установки нового Eclipse, ADT, в " Android SDK Manager", я не имел никаких SDK платформы установлен. Так я установил API 19 SDK платформы и усилитель ; Документация и усилитель ; Источники . Я бы установить также API 9, но по какой-то причине он в SDK Manager, отсутствуют.

Во всяком случае, после этого я редактировал андроида : minSdkVersion = " 10 " -> [ Сохранить] -> снова изменен на Android: minSdkVersion = " 9 " -> [ Сохранить] ... Ипроблема не было.

3Sharky @ go to your Manifest click on Uses Sdk change Min SDK version to 9 or something else and press ctrl+s (save) error should disappear now change Min SDK version back to your original value

Это решило его для меня.