Этот шаблон требуется создать цель API версии по меньшей мере 14, атекущая версия 8

? Vibhor Bhardwaj @ | Original: StackOverFlow
---

Я работаю с Android Developer Tool с долгого времени без issue.Recently я обновил свой ADT и теперь я не могу создать простую деятельность по ( New-> противном > Android деятельности) .Это предоставляет только возможность создать Action Bar Деятельность .

Итак, как создать простое мероприятие, с видовыми  Этот шаблон требуется создать цель API версии по меньшей мере 14, атекущая версия 8

Мой ADT версия 22.6

---

Top 5 ответ

1Mdlc @

Почему это происходит Шаблон, который вы пытаетесь добавить использует функции (как в ActionBar ), что требуетуровень API выше, чем 14, в первом шаге мастера, вы выбрали 9. А с 9 и LT ; 14 вы получите эту ошибку.

What can I do

Chose an higher minimum API level (at least 14 for this template). Go back to the first step and change the minimum api level. Chose a different template that is more compatible, by going back one step and select the most basic template.

Какие я должен выбрать Если вы считаете, что это не имеет значения, использовать апи уровень выше, чем 14 ( так устройство не будет работать на сэндвич крем пре- льда устройств), вы должны обязательно взять первый вариант. Если вы не возражаете против использования более шаблон базового пользовательского интерфейса, чтобы начать с, и вы действительно требуют ваше приложение работать на предварительно льда сэндвич крем устройств. Вы должны выбрать второй вариант.

Что делать, если я хочу как Вы можете использовать библиотеку поддержки, таким образом, вы можете наслаждаться Прикладной программный интерфейс 14+ особенности в отношении предварительной API 14 устройств . Некоторые считают его более трудным для настройки и усилителя ; использовать все же. https://developer.android.com/tools/support-library/setup.html Есть также образцы доступны .

EDIT: В ступеньку ниже, вы можете выбрать тип шаблона :, заметить галочку " создать активность ", просто снимите его .  Этот шаблон требуется создать цель API версии по меньшей мере 14, атекущая версия 8

2hunt @

Когда вы создаете проект, то необходимо установить параметры : мин SDK, целевой SDK и компилировать с . Вы можете установить мин SDK до 10, цель SDK до 10, но " Компиляция с " установлен в API 14 .

3AWT @

Обойти этого раздражения будет установить уровень API до 14, создать новый вид деятельности, а затем изменить уровень API к тому, что вы хотите его видеть. Это, кажется,проблема с этой версией ADT и мастера создания нового активность .

Это работало раньше, но я недавно обновил ADT и теперь я вижу проблемы по проектам, я не изменил .

Я делаю это, чтобы создать новые виды деятельности и не видели никаких проблем пока .

4user3380823 @

Что установил ее для меня был в Eclipse, будет Project > Properties > Android последующей проверкой высокий уровень API в проекте цель сборки коробки ( API 19 для меня)