Не нашли класс по пути : dexpathlist

? Rodolfo Perottoni @ | Original: StackOverFlow
---

Серьезно, я не знаю, что делать, чтобы решить эту проблему. Моя Android проект работает нормально, пока я не нужно импортировать библиотеку с Maven. Так что, все началось рушиться .

То, что происходит : Когда я начинаю мое заявление, появляетсяследующее сообщение об ошибке на LogCat и Android рассказывает, что мое приложение перестало работать. Я искал для этого подобная ошибка здесь и на остальной части интернета, но все, что люди ничего не работает для меня .

Error: java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.example.buscaserra/com.buscaserra.main.ActivitySplash}: java.lang.ClassNotFoundException: Didn't find class "com.buscaserra.main.ActivitySplash" on path: DexPathList[[zip file "/system/framework/com.google.android.maps.jar", zip file "/data/app/com.example.buscaserra-2.apk"],nativeLibraryDirectories=[/data/app-lib/com.example.buscaserra-2, /vendor/lib, /system/lib]]

Декларация и пакеты:  Не нашли класс по пути : dexpathlist  Не нашли класс по пути : dexpathlist

Путь сборки :  Не нашли класс по пути : dexpathlist

Пожалуйста, я не знаю, что еще можно сделать. Мой срок проект находится рядом, и им в отчаянии. Спасибо заранее.

---

Top 5 ответ

1code4cause @

Есть ли у вас необходимые проекты по пути сборки? Не могу сказать с экрана выстрел, но проверить вкладку "Проекты " . Вы, возможно, случайно добавил проект библиотеки в качестве необходимой проектной вместо этого. Удалить проект на вкладке, а затем Проекты -> Свойства . Нажмите Android, добавьте проект в виде библиотеки, а здесь ...

2Federico @

Такая же проблема здесь. То, что работало для меня было добавлять Android- Опорно- v4.jar как библиотеки, и убедившись, что он был установлен на Свойства проекта - > Build Path -> Заказать и усилитель ; экспорт . Было отмечено, https://code.google.com/p/android/issues/detail?id=61710

3Rodolfo Perottoni @

В то время я был разработке этого приложения, я не мог тратить время на поиск для способ, чтобы исправить эту проблему. В качестве обходного пути, я скопировал содержимое этого проекта на новый . Проблема решена .

4JDJ @

Убедитесь, что все совместимость либерал банки, что вы используете в вашем главном проекте (например, Android, поддержки- v4.jar ) одни и те же версии, как те, которые используются в любой из проектов, что ваш основной ссылок проекта .

У меня была эта же проблема, и то, что решается это было скопировать и вставить Android- Опорно- v4.jar из другой библиотеки проекта ( что моя главная проекта ссылки ) и вставить его в папку / Libs моих главных проекта.