Android Студия Gradle инструмент сборки Редакция

? Gabriel Matusevich @ | Original: StackOverFlow
---

У меня естьAndroid Project в Android Студия 0.5.9 и Gradle бросает эту ошибку:

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

Я уже установил SDK инструменты разработки, пересмотра 19 из диспетчера SDK, и вот моя build.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

Как я говорю Gradle использовать инструменты для сборки 19, если он уже установлен ?

EDIT: Я отметил другой ответ, как лучший ответ, потому что это был тот, который работал для большинства людей

---

Top 5 ответ

1Gabriel Matusevich @

Я нашел эту проблему, build.gradle был по ту папку

2Azurai @

Я только недавно обновил свой андроид студию на 0.6.0, и он давал мне ту же самую проблему . Но моя сборка была 19.0.3, вместо 19.1.0 . Я изменил buildToolsVersion " 19.0.3 " для - > " 19.1.0 ", которая это заставило Gradle загружать обновления . Я перезагрузил свой Android Studio, иошибка ушла. Не знаю точно, как это объяснить, но я думаю, что это заставляет его скачать патч за пределами площадки Maven, и делает его справедливости за кулисами. И так же, как сказал Габриэль Матусевич ,build.gradle находится ProjectFolder -> AppFolder -> build.gradle

Исключение : Я havn't закончено испытал это, но я заметилGradle был загружен с сайта, я havn't добавлены или удалены код или запуске приложения еще . Таким образом, чтобы быть уверенным, помните, количество buildToolsVersion вы имели прежде!

3Jorge Vieira @

Открыть Android SDK менеджер и убедитесь, что у вас есть инструменты для сборки 19,1 загружены. Двойная проверка .

Затем найдите построить / app.gradle и изменить номер buildToolsVersion в '19 0,1 ' :

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }
4Xexiz @

Я была такая же проблема сегодня утром после обновления до .6.0 . Вы должны изменить вам Gradle версию в /projectName/build.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Откройте менеджер SDK и скачать новую версию специальных средств, 19,1 затем измените следующую строку в /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

А затем синхронизировать Gradle файлы, и вы должны быть хорошо идти !

5RoQ @

Привет мне после скачайте последнюю версию Android SDK Tools, изменить Android Версия F4 (Настройки модуля)

https://www.dropbox.com/s/9ypuepxfwlcp4e5/Captura%20de%20pantalla%202014-06-10%2000.45.38.png