Ошибка в Eclipse, с appcompat_v7

? jkally @ | Original: StackOverFlow
---

Будучи новым для Android developent я последовалпростой учебников, построен новый андроид проект, принимая все по умолчанию ( его строили для KitKat ). К моему ужасу я маркированного планируемого проекта - appcompat_v7, наряду с ошибками :

Контейнер ссылки " Android зависимостей " не существующей библиотеки " C : Люди ... workspaceappcompat_v7 inappcompat_v7.jar "

и в два разапосле

Проект не может быть построен до ошибки пути сборки не будут решены

Естьбыстрый способ, чтобы исправить это ? Является ли этопризнаком того, как сложно, и прослушивается неприятные сюрпризы обучения Android будет ?

( Надеюсь, что это не будет похоже на обучение IOS 6 лет назад ... )

---

Top 5 ответ

1ZygoteInit @

Хитрость заключается в том, что вам нужно, чтобы очистить и усилитель ; построить проект appcompat_v7 . Перейти к Project -> выберите Clean -> выбрать проект . Еслипроект не строится автоматически, щелкните правой кнопкой мыши на проекте в пакете изучить и выбрать Build Project . Теперь.jar файл будет создан в папке bin проекта. После этого, чистый & Amp; построить все проекты, которые ссылаются на appcompat_v7 .

Note also that:

1. Вы должны иметь самые последние версии SDK Tools / Строительные инструменты / Платформа Tools. Если вы попробуете это, и это не сработает, то перейдите к диспетчеру Android SDK и убедитесь, что у вас установлены последние версии необходимых инструментов.

2. В случае, если ваш проект требует только уровень API 14 ( Ice Cream Sandwich ) & Amp; выше, выберите уровень API 14 для " минимально необходимый SDK " в мастере создания проекта, когда вы создаете новый проект. Теперьappcompat_v7 библиотека не будет требоваться для этого проекта, иприложение будет использовать родной класс ActionBar, который присутствует в AOSP строит из ICS года .

2prabhakaran @

Нужно обновить менеджер SDK

нажмите ур SDK значок менеджера в ecilipse затем обновить андроид поддержки репозитория в статистов

then

перейти к Файл- > импортно > существующего проекта

около bundle- > sdk- > вне- > android- > несущий > v7, чтобы рабочее пространство

после импорта v7 в рабочую перейти по Lib папки выбрать как банку и щелкните правой кнопкой мыши и выберите построить в рабочую затем снова щелкните правой кнопкой мыши v7 проект перейти по Java Build Path выберите флажок и нажмите кнопку Применить и ОК ..

если у обновили SDK следуйте этим шагам

step 1:

Щелкните правой кнопкой мыши ур проект затем перейдите к

собственность- > выбрать Java Build Path

step 2:

нажмите кнопку Добавить внешний банку

Step 3:

Просмотр ур ADT пучка перейти к ур рабочей выберите папку,

Android -поддержка - v7- AppCompat -> Lib -> appcompat_v7.jar

3CyberSpy_zero @

Я была такая же проблема, и я попытался все mentionded выше советы и многое другое из, но никто не помог мне решить мою проблему . Мое решение было создание Progect с минимально необходимой SDK API 14 : Android 4.0 ( IceCreamSandwich ). Делать это путь Затмение не будет создавать appcompat_v7 проект.

Кроме того, я нашел еще один, лучше, решение:

Go to Android SDK Manager and install Android 5.0.1 (API 21) or newer. If you don't use the emulator you can install only SDK Platform and Google APIs; Go to appcompat_v7 -> Properties -> Android and check Android 5.0.1 in the Project Build Target; Then go to Java Build Path -> Order and Export and check Android 5.0.1; Do the same procedure for your project. 4BK Manly @

Appcompat_7 ошибка решена!

Привет, им полный новичок, я решить мою проблему, перейдите к SDK Update Manager / установить всеновые Android SDK инструменты для сборки (как я не уверен, что есть что мне нужно обновить / установить так я обновить / установить все инструменты разработки . После обновлено / установлено все новые инструменты для сборки я закрыл затмение и возобновить затмение снова. Если вы видите какие-либо ошибки снова? перейти на верхней панели мыши по проекту и выберите Очистка . и запустить приложение снова, и я думаю, что это будет прекрасно работать ..

5Don 3000 @

Принимаем ответа работал для меня, но только после того как я установлена ​​последняя Java JDK (который былрешением проблемы, описанных здесь http://stackoverflow.com/questions/26474298/android-parsing-data-for-android-21 -failed )