Google ADT / поддержка GWT для затмения 4,4 (Luna )

? MTilsted @ | Original: StackOverFlow
---

Есть кто-нибудь получил окончательную версию затмения 4,4 для работы с ADT ( Android развития) и / или Google Web Toolkit (GWT) .

Похоже, что GWT / ADT плагины не работает с затмения 4.4, так естьтайное место для загрузки новых версий или я должен продолжать использовать 4,3 - (

Изменить: Поэтому я подумал, ADT не работает, чтодокументация ( http://developer.android.com/sdk/installing/installing-adt.html ) говорит, чтоплагин называется " ADT Plugin ", который это не так.

---

Top 5 ответ

1user3396807 @

For adt,

Справка -> Установить новое программное обеспечение - >    https://dl-ssl.google.com/android/eclipse/ -> не выделить все

(он работал именно так для меня) я выбрал все, кроме встроенных средств разработки ( я думаю, вы не нуждаетесь в них, если вы debelop в Java ), и это хорошо работает для меня .

2raywang @

ну ...плагин GWT на самом деле не может работать с Луной выпуска, поскольку он имеет расслоение зависимостей для затмения core.runtime [ 3.8.0,3.10.0 ), то здесь, " ) " означает, что не включает в себя 3.10.0 wihich используется в Луна однако, это может был избавиться от путем изменения файла OSGi расслоения и тогда это будет прекрасно работает с Луной, по крайней мере для меня на данный момент.

1 скачать последнее обновление сайта почтовый файл из Google затмения сайте плагина 2 распаковать его 3, то вам нужно будет изменить 2 файла во-первых,

OSGi META INF / файл манифеста включены в банку с именем * GDT * e42 ( извините, забудьте полное имя, вы можете найти его, когда вы пытаетесь установить плагин, Луна будет жаловаться, что некоторые DEP пучок пропустил ), который расположен в плагинах директорию, просто измените core.runtime версию с 3.10.0 ) в 3.10.0 ]

еще один должен быть contents.jar (возможно артефакты . банок ), то же выше

Теперь вы можете установить плагин, если вы уже установилиEclipse RCP

Однако, установить будет не удалась, посколькуmd5 хеш изменилось,

наконец, скопировать ожидается md5 из диалогового окна сообщения об ошибке, чтобы заменить старый значение MD5 в artifacts.jar (возможно contents.jar )

Теперь переустановить плагин, он должен работать сейчас

UPDATED:

Может быть, вы должны удалить ножки пучка версию с MANIFEST.MF в com.google.gdt.eclipse.platform.e42 банку и изменить версию " 0.0.0 " из content.xml на content.jar

3MrTux @

Google только что выпустила свой официальный SDK для Eclipse, Луна : https://developers.google.com/eclipse/docs/getting_started

4ojonugwa ochalifu @

Если вы используете опцию Help----->Install New Software, вы можете столкнуться с это сообщение об ошибке, как я сделал, пытаясь установить Android плагин.

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase. session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=). Error reading signed content. error in opening zip file

Мое решение было пройти через Help-->Eclipse Marketplace, а затем искать "Android" Выберите плагин из результатов поиска и установить его оттуда.