Обновление Затмение с инструментами для Android развития 23 ст.

? greywolf82 @ | Original: StackOverFlow
---

Я обновил Затмение с новыми инструментами SDK (Откр 23 ), но теперь при запуске Eclipse, я получаю сообщение об ошибке:

Это Android SDK требуется Android Developer Toolkit версии 23.0.0 или выше . Текущая версия 22.6.3.v201404151837-1123206 . Пожалуйста, обновите ADT до последней версии .

Обновления не были обнаружены " Проверить наличие обновлений " . Если я пытаюсь " Установить новое программное обеспечение ", я могу увидеть версию 23, но я не могу обновить из-за следующей ошибки:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

После загрузки последней ADT с веб-сайта, кажется, есть еще одна проблема. С SDK Tools ред. 23 ProGuard не установлен,папки SDK dir/tools/proguard отсутствует, и другие инструменты отсутствуют. Эта версия содержит ряд ошибок .

---

Top 5 ответ

1Daniel Díaz @

UPDATE : Google выпустила ADT v23.0.2 . Это решило многие проблемы предыдущей ADT версии 23 .

Step-by-step:

Help -> Install New Software... For "Work with", select the Android source https://dl-ssl.google.com/android/eclipse Обновление Затмение с инструментами для Android развития 23 ст. Tick ADT v23.0 for installation, then click "Next" Eclipse will show "Install Remediation Page" since there is conflict with previous version. (If it does not, see below.) Select "Update my installation to be compatible with items being installed" to uninstall the old version and install the new one. After that, proceed with the usual steps Обновление Затмение с инструментами для Android развития 23 ст.

Примечание: Когда я установил новую версию ADT, я не включают в себя новую версию " Android Native инструменты для разработки « пакета . Вместо этого, я установил остальные пакеты, а затем установлен "Android встроенных средств развития». По причине, если я пытаюсь установить все новые пакеты программ, включая "Android Tools Родной развития» ,сбой установки.

UPDATE : Если нет " Восстановление страницы ", http://stackoverflow.com/a/9097282/755804 Но естьриск удаления затмить себя .

2bluewhile @

Для меня это помогло удалить Android 4.4W, который также API 20 и может бытьпричиной для конфликта. Таким образом, только установить Android 4.4W или Android L, пока они не исправить.

И (опять же, это может быть только для меня ) это работает только в Android Студия не Затмения ...

3Rajat Sharma @

Я сделал следующее, чтобы устранить проблему .

Перейти к http://developer.android.com/sdk/installing/installing-adt.html и скачать последнюю ADT ZIP файл ( в нижней части страницы) .

Перейти к Затмение - > Help -> About Eclipse, -> Дополнительные сведения об установке

Удалить Android DDM, Android Developer Tools, иерархия Viewer, собственные средства и инструменты развития, TraceView, и т.д., 22.x версии.

Помощь -> Установить новое программное обеспечение - > Добавить - > Архив - > выбираем скачанный ZIP файл в шаге 1 .

Выберите все последние версии всех 23, которые я удалил в шаге 3 и принять условия лицензионного соглашения .

Перезапустите Eclipse, и он фиксирует мою проблему .

4stevyhacker @

На ADT в комплекте Eclipse, я должен был сначала удалить ADT, а затем сделатьновую установку . Чтобы удалить ADT плагин из Eclipse, выберите Справка > О Затмение > Детали установки . Выберите ADT плагин, нажмите кнопку Удалить. После удаления установки ADT из меню Справка> Установить новое программное обеспечение.

5Biljana @

DO NOT DO THIS

Внимание : Пожалуйста, см комментарии ниже этого ответа . Эти шаги оказали негативное воздействие на многих людей.

Click Help / Install new software... Click on What is "already installed" (as in picture below) In the new window you can uninstall the old ADT (uninstall Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Development Tools and Tracer for OpenGL ES) Restart Eclipse Then again click on Help / Install New Software Choose ADT... Install

Я надеюсь, что это помогает!

Обновление Затмение с инструментами для Android развития 23 ст.