Использование материале темы на L просмотра

? Niek Haarman @ | Original: StackOverFlow
---

Предварительный L Разработчик настоящее время на уровне API 20. Однако, по-видимому темы требуют 21 уровня API.

@android:style/Theme.Material.Light.DarkActionBar Требуется уровень 21 API

Является ли этоошибкой, я делаю что-то неправильно, или это просто не возможно использовать материал на L Preview ?

---

Top 5 ответ

1Niek Haarman @

Разработать на @ комментариях Панини, я использую это в моем build.gradle :

android {
    compileSdkVersion 'android-L'
    buildToolsVersion '20.0.0'

    defaultConfig {
        minSdkVersion 16
        targetSdkVersion 'L'
        versionName buildVersion.version
    }

/* ... */
}

Размещение styles.xml в папке values-v21, позволяющую тему, чтобы работать на L просмотра.