Android Студия говорит использовать Gradle 1,10 - но новая версия 1.12 ?

? KickingLettuce @ | Original: StackOverFlow
---

The error:

The project is using an unsupported version of Gradle.  Please use version 1.10.


My `gradle.build` file says this:

dependencies {
      classpath 'com.android.tools.build:gradle:0.12.+'
}

Насколько я знаю,выше линия является правильным. Мой gradle-wrapper файл говорит:

distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip

Это произошло, когда я скачал новейшие Android Студия бета ( ст.8 ) и пытался импортировать приложение, которое было, что я предполагаю, этостарая версия Gradle .

Кроме того, когда я нажимаю " Fix Gradle Wrapper and re-import project ", ничего не происходит.

---

Top 5 ответ

1The Metal Beard @

Существуетразница между версией Gradle и Gradle Android версии плагина ( 0,12 . +). Похоже, вы должны Gradle версию 1,10, не думаю, что более поздние версии supperted с помощью плагина Gradle Android еще . Во всяком случае, я думаю, убедившись, что вы используете Gradle 1,10 версию решим этот вопрос .

2The End @

Если вы хотите изменить Gradle - оболочки в нижней версию, вы должны изменить distributionUrl в

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

а затем повторно запустить задачу оболочки . Если этого не достаточно просто удалить папки .gradle и gradle и файлы gradlew и gradlew.bat . Перезапуск обертка, и он загружает gralde 1,10

С Gradle были некоторые серьезные изменения API, начиная с версии 1.10 и 1.12 вы не можете построить любой проект с более высокой версии, то плагины строить с . Так что, еслиандроид плагин строить с Gradle 1,10, вы должны использовать ту же версию