Не удается обновить ADT плагин в Eclipse, до версии 23.0.0 или выше

? adamhala007 @ | Original: StackOverFlow
---

Я новичок в Android программирования. Моя проблема в том, что я не могу обновить ADT . Проблема началась, когда после долгого времени я обновлен в Android SDK менеджер для Android SDK Tools. Тогда я пытался импортировать проект в рабочее пространство . Но я не мог импортировать это, потому что каждый раз, когда я нажал на кнопку Готово, ничего не произошло. Тогда я закрыл Затмение и открыл его снова, и показал мне следующую ошибку :

Не удается обновить ADT плагин в Eclipse, до версии 23.0.0 или выше

Я нажал на проверить наличие обновлений, но ничего не нашли . В Интернете я нашел URL ( https://dl-ssl.google.com/android/eclipse/ ), так что я нажал Справка -> Установить новое программное обеспечение ...-- > Добавить - > и вставить это URL . Когда я нажал Далее, он показал мне список вопросов, которые я хотел, чтобы установить, а также об ошибке :

Cannot complete the install because of a conflicting dependency.
 Software being installed: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
 Software currently installed: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
Only one of the following can be installed at once: 
Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger 23.0.0.1245622)
Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger 21.0.0.v201210310015-519525)
Cannot satisfy dependency:
From: Tracer for OpenGL ES 23.0.0.1245622 (com.android.ide.eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
To: com.android.ide.eclipse.gldebugger [23.0.0.1245622]
Cannot satisfy dependency:
From: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.android.ide.eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
To: com.android.ide.eclipse.gldebugger [21.0.0.v201210310015-519525]

Кроме того, я где-то читал, что я должен попытаться заменить папку плагинов с обновленными плагинов папки, так что я пытался переименовать " плагины " папку в папке затмение " pluginsx " и вставить новый Кого я скачал с сайта HTTP: //developer.android.com/sdk/installing/installing-adt.html . После этого я не мог открыть Eclipse.

Этот сайт ( http://stackoverflow.com/questions/24437564/update-eclipse-with-android-development-tools-23 ) также примерно в то же проблемы, как у меня, и естьответ, который принимается как решение вопроса . Так что я попытался также скачать http://dl.google.com/android/android-sdk_r22.6.2-windows.zip, и скопировать эти 3 вещи, чтобы папки, которые были упомянуты в комментарий ниже, но я до сих пор та же проблема, ничего не изменилось .

Так что теперь у меня нет ни малейшего представления, как решить эту проблему. Может кто-нибудь помочь мне, пожалуйста?

Спасибо заранее.

---

Top 5 ответ

1serifsadi @

Помощь -> Установить новое программное обеспечение - > Что уже установлен ?

Затем выберите "Android DDMS, Andoid Devlopment Инструменты, Android Hierarcy зрителя, Android инструменты разработки на платформе, Android Traceview, Tracer для OpenGL ES" и нажмите кнопку Удалить .

После всего этого шага, попробуйте Добавить ссылку ( https://dl-ssl.google.com/android/eclipse/ ) и имя ADT Plugin . Эта ссылка будет получить последнюю ADT Plugin. Таким образом, вы переустановить ADT .

2Stuart Siegler @

Ни один из этих "Обновление" только ответ не работает для меня .

Решение я использовал, чтобы удалить ADT (от удалении приложения для Android ADT )

Help > About Eclipse > Installation Details

Выберите все Android модулей ( с префиксом com.android.ide ...)

и удалить их ( Uninstall ... ) и повторно добавьте библиотеки из

help > Install new software

Как указано выше ....

3androider @

Единственное решение, которое работает для меня было загрузить текущую Затмение ADT пачку из Android http://developer.android.com/sdk/index.html

После загрузки это, я скопировал мой текущий SDK в папку, как ... / развития / SDK . Тогда я удалил SDK, поставляемой с этой новой Bundle.

Я положил ADT Bundle в ... / развития / ADT -расслоения -.... После запуска, вы Jave сообщить новое место SDK в Window > Preferences > Android, так и в SDK Откуда вы положили новый путь SDK. В моем случае : ... / развития / SDK .

Конечно, вы можете положить в папку SDK внутри новой папки ADT Bundle, но я делаю это так, потому что я использую Android Студия, так что я указываю два Иды к тому же SDK.

После завершения этого и быть уверены, что все работает я удалил старую папку ADT Bundle .

4ZakiMak @

Установка ADT являетсясерьезной проблемой, специально при обновлении . Также иногда это простоболь, чтобы установить ADT, предоставляя прямой ссылке. Часто Затмение будет простаивать во время отображения "Расчет требования и зависимости " .

Я нашел это проще порой необходимо сначала удалить все 7 компонентов :

-Android DDMS -Andoid Devlopment Инструменты -Android Hierarcy просмотра -Android Родные Средства разработки -Android Traceview -Tracer Для OpenGL ES -Google App Engine Инструменты для Android ( если установлен)

Затем скачайте последнюю ZIP / Архив из http://developer.android.com/sdk/installing/installing-adt.html

Установите Архив От помощи > Установить новые Software- > Add-> Архив  Выберите загруженный ZIP, укажите имя для нее и следовать стандартный процесс установки.