Это Android SDK требуется Android Developer версии Toolkit 23.0.0 или выше

? Kalpesh @ | Original: StackOverFlow
---

Я получаю следующую ошибку когда я начинаю мой Eclipse.

Это Android SDK требуется Android Developer версии Toolkit 23.0.0 или выше

И когда я пытаюсь установить обновление из меню Справка> Установить новое программное обеспечение ... используя ссылку обновления затмение https://dl-ssl.google.com/eclipse/plugin/4.2

Это дает мне следующее сообщение об ошибке :

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
Software currently installed: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
Only one of the following can be installed at once: 
ADT XML Overlay 23.0.1.1256982 (overlay.com.android.ide.eclipse.adt.overlay 23.0.1.1256982)
ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.android.ide.eclipse.adt.overlay 22.6.3.v201404151837-1123206)
Cannot satisfy dependency:
From: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
To: overlay.com.android.ide.eclipse.adt.overlay [23.0.1.1256982]
Cannot satisfy dependency:
From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
To: overlay.com.android.ide.eclipse.adt.overlay [22.6.3.v201404151837-1123206]

Что же мне теперь делать ?

---

Top 5 ответ

1Dhawal Sodha Parmar @

не нужно делать ничего ,

просто скачать новую затмение, установить ADT 23.0.0 снизу ссылку

https://dl-ssl.google.com/android/eclipse/

Ваша проблема решить ...

его произошло потому, что у вас есть SDK 23.0.1 и ADT 23.0.1 обновление не доступно ....

yesterday i have same issue, i have solved that.. 2user285oo6 @

Как вы сделали обновление до SDK 23,0 без обновления ADT он покажет этот вид ошибки, как вы упомянули, на скриншоте .

Просто модернизации SDK для 23,0 не имеет смысла до тех пор, пока вы не обновите связанную инструмент развития в ADT.

Следуйте инструкциям

First delete the SDK 23.0 and update the ADT to 23.0 For doing the update you need to click on Install new software from help and choose the ADT/ https://dl-ssl.google.com/android/eclipse/ under the link upon which you get the new Development tools to update click all >next to continue . Upon successful completion you can now update the SDK to 23.0.

Примечание: - Многие из тех, кто пытался обновить SDK есть сталкиваются с проблемой не удается завершить установку из-за Зависимость от конфликта  Это Android SDK требуется Android Developer версии Toolkit 23.0.0 или выше

Таким образом, ее лучше просто придерживаться 22.6v в ADT. Обновление 23,0 заполнено с ошибками, и это займет некоторое время, чтобы исправить ошибки

3Kikiwa @

Если у вас есть конфликт с предыдущей версии:

Select Help > Install New Software Click on already installed Select all Android software on version 22.* Click on Uninstall Work with: https://dl-ssl.google.com/android/eclipse/ Select Developer Tools and Next Next, Accept the license agreement and Finish.

EDIT: Этот трюк, вероятно, не более необходимым !

Попробуйте обновить SDK инструменты, чтобы 23.0.2+ и строить & Amp; платформы инструменты для REV 20 раньше.

4Kalpesh @

Лучшее решение для этого, чтобы загрузить новую ADT из http://developer.android.com/sdk/index.html

5Joff @

Kalpesh НЕ удаляйте SDK 23,0 он будет удалять папку " инструменты ", и вы не сможете запустить SDK Manager, после этого. Я знаю, потому что я только что сделал это. Плохой предложение !

Решение от Kikiwa работал для меня.