Использование 1,7 требует компиляции с Android 4.4 ( KitKat ); В настоящее время с помощью API 14

? user3810543 @ | Original: StackOverFlow
---

Так я недавно перешел цель моей андроид проекта 4.0. Теперь у меня есть практически ошибки в каждой строке и ошибки "Использование 1,7 требует компиляции с Android 4.4 ( KitKat ), в настоящее время с помощью API 14 " на консоли. Так что мой вопрос, как я могу изменить эту работу с API 14 и скомпилировать ? спасибо.

---

Top 5 ответ

1Eran @

В Eclipse : Щелкните правой кнопкой мыши проект -> Свойства - > из боковой панели, выбрать " Java Compiler ", а затем изменить уровень Compiler соответствия на 1,6

2Justin @

Я не согласен с Eran, эта ошибка причину, установив Project build target до 4,0 ( API 14 ). Если изменение Java 1.6, вы не можете использовать Java стиль 1,7 содэ, напр : ArrayList myArrayList = new ArrayList<>(); .  Чтобы исправить это, установите свою цель до 4,4 (API 19 ) или выше.