Попытка обновить ADT - получение " противоречивые зависимость " ошибка

? uj- @ | Original: StackOverFlow
---

Я имел ряд проблем с тех пор, когда я пытался импортировать андроид проект.

Расположение мой SDK не был установлен в настройках ( хотя это было до и ADT работает прекрасно ) . Когда я пытаюсь установить путь к папке SDK, он говорит

Это Android SDK требуется Android Developer Toolkit версии 23.0.0 или выше . Текущая версия 22.6.2.v201403212031-1085508 . Пожалуйста, обновите ADT до последней версии .   Поэтому я стараюсь, чтобы обновить затменияпосле, как это предлагается на друга, так сообщению (с " Проверить наличие обновлений " продолжает говорить мне, что нет доступных обновлений :

Помощь -> Установить новое программное обеспечение - > p2repo - https://dl-ssl.google.com/android/eclipse/ - > Проверить инструменты для разработчиков - > Далее          И вот, когда я получаю следующую ошибку:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
Only one of the following can be installed at once: 
ADT CDT Integration 23.0.2.1259578 (com.android.ide.eclipse.ndk 23.0.2.1259578)
ADT CDT Integration 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk 22.6.2.v201403212031-1085508)
Cannot satisfy dependency:
From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk.feature.group 22.6.2

Cannot satisfy dependency:
From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]

Cannot satisfy dependency: 
From: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
To: com.android.ide.eclipse.ndk [23.0.2.1259578]

Cannot satisfy dependency:
From: Android Native Development Tools 22.6.2.v201403212031-1085508  (com.android.ide.eclipse.ndk.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk [22.6.2.v201403212031-1085508]

Как я могу успешно обойти эти ошибки и обновлять затмение ?

---

Top 5 ответ

1The_ehT @

Просто удалите текущий ADT версия 22.6.2.v201403212031-1085508 меню Справка > Детали установки > установленного программного обеспечения, а затем выберите ADT ( старая версия) > нажмите кнопку Удалить. Теперь переустановить последнюю ADT . Таким образом, я смог обновить ADT до текущей версии, надеюсь, что это помогает. Примечание: Это не будет работать на ADT- расслоения.

2Lightshadow @

Сегодня я получил ту же ошибку, как вы :

Это Android SDK требуется Android Developer Toolkit версии 23.0.0 или выше . Текущая версия 22.6.2.v201403212031-1085508 . Пожалуйста, обновите ADT до последней версии .

YOUR MESSAGE:

Это Android SDK требуется Android Developer Toolkit версии 23.0.0 или выше . Текущая версия 22.6.2.v201403212031-1085508 . Пожалуйста, обновите ADT до последней версии .

Я установил его в 5 минут :

1 - Убедитесь, что вы до сих пор есть файл Zip ( меня это " ADT- расслоение -Windows- x86_64-20140321 " )

2 - Скопируйте содержимое Zip, где вы хотите, чтобы это было

3 - Это как 1,30 ГБ ( я думаю), поэтому в зависимости от вашего компьютера это может занять несколько минут

4 -Once, она копируется, откройте его.

5 -Go в папке затмения, а затем откройте приложение Eclipse ( вы даже можете прикрепить его на панель задач, если вы используете егомного )

Я имел эту проблемунесколько раз, и это всегда работает для меня.

3Lightshadow @

Для Санджай Манохаром :

В основном, когда вы загрузили затмение, это было в виде архива . Тебе нужно извлечь файлы, чтобы использовать его содержание. Файл, который я скачал был назван " ADT -расслоение -Windows- x86_64-20140321 ", и я получил его от " https://developer.android.com/training/basics/firstapp/index.html " .

Если вы используете Eclipse, вы, вероятно, есть файл архива в ваших закачек, поэтому нет необходимости загружать его заново .

Если бы я был вам, я хотел бы сделать файл с именем "Android " и в ней поместите файл ZIP ( для использования в качестве будущей резервной копии, если у вас есть подобные проблемы)

Я хотел бы также создать папку с именем рабочее пространство для всех моих проектов, ипапка с именем ADT, в которой я бы извлечь содержимое архива.

Это было бы папки внутри " ANDROID " :

-ADT (- > Содержит распакованные файлы из почтового индекса файла " ADT -расслоение -Windows- x86_64-20140321 " )

-workspace (- > содержит мои проекты )

-adt -расслоение -Windows- x86_64-20140321 (- >почтовый файл )

Извините за создание нового ответ, я не имею репутацию ...

4priya @

Удалите все конфликтующие компоненты. В моем случае, Open- GL, DDMS, ADT и т.д., были конфликтует с обновлением. Так я удалил все из них, используя ..

Help- > о затмении SDK- > Установка детали-> выберите компонент для uninstall- > Удалить

Тогда обновить ADT .

Help- > Установить новые программно > Выберите сайт обновления ADT ( https://dl-ssl.google.com/android/eclipse/ если нет добавить его ), имеющихся в наличии S / W -сайтов. И обновить ADT .

5Ankit Sachan @

Просто выберите ADT из Инструменты разработчика в раскрывающемся