Разбор данных для Android л failed.Unsupported major.minor версии 51.0

? sasu @ | Original: StackOverFlow
---

После установки ADT плагин для Eclipse, я попытался сделать новое приложение Привет, мир Android.

Но я встретился с следующее сообщение об ошибке, когда я попытался открыть новое приложение для Android . Я работаю с JDK 7.0 и JRE 7.0. Я сначала работал с JDK 6.0, но встретил с такой же ошибкой, поэтому я удалил его и установили JDK 7.0 и изменили настройки путей соответственно.

Ошибка явно :

Загрузка данных для Android L ( Preview) столкнулся с проблемой . Разбор данных для Android л failed.Unsupported major.minor версии   51.0 .

Мой уровень соблюдения также изменен на JDK только 1,7 . И я также изменил мою JRE соблюдения до 1,7 .

---

Top 5 ответ

1Sree14 @

Пожалуйста, проверьте следующее .

Ensure that you have restarted your system after specifying the path name. You can look for the following icon on your eclipse's layout screen. !( http://i.stack.imgur.com/WoX58.png ) The "20" specifies the android version to use when rendering layouts. Change it and see. Last but not least review your ADT configurations. Hope this helps. 2AJP @

Вы можете " решить " путем удаления л SDK Android с помощью диспетчера Android SDK .

Не удовлетворительное.

Edit

Я думаю, http://stackoverflow.com/a/24566948/539490 эффективно предлагая то же самое, но без деинсталляции ( вместо этого просто выберите версию API, что на самом деле работает ) .

3Ligen Yao @

Проверьте вашу версию JDK . Она должна быть JDK1.7 . JDK 1.6 не работает.

4tounaobun @

Просто удалите Android L платформ. Перейти на андроид каталог SDK.

ADT -расслоение -MAC - x86_64-20140321 / SDK / Платформы / Android -L

Удаление папки Android- L и перезагрузите затмение.

5Haimanti @

Иногда это может быть просто потому, чтоуровень соответствия компилятора не установлен должным образом в настройках Eclipse, Java Compiler .

Перейти к Eclipse, предпочтения, под Java сечение, > перейти к компилятора, а затем в уровне JDK соблюдения выберите 1,7