Импорт android.support.v7 не может быть решен

? chatfun @ | Original: StackOverFlow
---

Я новичок в Android. В настоящее время, у меня есть adt-bundle-windows-x86-20131030.zip (Windows 32 бит) установлен, - и успешно установили Android SDK и Eclipse. Кроме того, я обновил все в менеджере Android SDK. Теперь, я работаю в Android у- 4.4.2

Мой проект успешно работает, но когда я импортировать android.support.v7.app.ActionBarActivity; и import android.support.v7.app.ActionBar;проект не будет отлаживать . Я получаю ошибку The Import android.support.v7 cannot be resolved

Я искал в Google и установлены Android Support Library, а затем добавил: v7 в моем проекте .

File->Import (android-sdkextrasandroidsupportv7). Choose "appcompat" Project-> properties->Android. In the section library "Add" and choose "appCompat"

Screenshot

Импорт android.support.v7 не может быть решен

Успешно добавлено в appCompat, но все еще я все еще получаю ошибку.

---

Top 5 ответ

1AlexFritz @

Перейти к вашему проекту в навигаторе, щелкните правой кнопкой мыши по свойствам .

Перейдите на вкладку Построить путь Java слева.

Перейдите на вкладку Библиотеки на вершине.

Нажмите кнопку Добавить внешние JAR.

Перейти к папке ADT Bundle, перейдите к SDK / дополнительные / Android / Поддержка / v7 / AppCompat / библиотеками .

Выберите файл андроид -поддержка - v7- appcompat.jar

Перейти к порядку и экспорт, и установите флажок рядом с новой банкой .

Click ok.

2Adjie @

В моем случае ,автоматически сгенерированный проект appcompat_v7 был закрыт. Так просто открыть этот проект в проводнике пакетов .

Hope this help.

3JohannB @

Я была такая же проблема каждый раз, когда я пытался создать новый проект, но, основываясь на выводе на консоль, это было из-за двух версиях Android- поддержки -V4, которые были различны:

[2014-10-29 16:31:57 - HeadphoneSplitter] Found 2 versions of android-support-v4.jar in the dependency list,
[2014-10-29 16:31:57 - HeadphoneSplitter] but not all the versions are identical (check is based on SHA-1 only at this time).
[2014-10-29 16:31:57 - HeadphoneSplitter] All versions of the libraries must be the same at this time.
[2014-10-29 16:31:57 - HeadphoneSplitter] Versions found are:
[2014-10-29 16:31:57 - HeadphoneSplitter] Path: C:Usersjbaurerworkspaceappcompat_v7libsandroid-support-v4.jar
[2014-10-29 16:31:57 - HeadphoneSplitter]   Length: 627582
[2014-10-29 16:31:57 - HeadphoneSplitter]   SHA-1: cb6883d96005bc85b3e868f204507ea5b4fa9bbf
[2014-10-29 16:31:57 - HeadphoneSplitter] Path: C:UsersjbaurerworkspaceHeadphoneSplitterlibsandroid-support-v4.jar
[2014-10-29 16:31:57 - HeadphoneSplitter]   Length: 758727
[2014-10-29 16:31:57 - HeadphoneSplitter]   SHA-1: efec67655f6db90757faa37201efcee2a9ec3507
[2014-10-29 16:31:57 - HeadphoneSplitter] Jar mismatch! Fix your dependencies

Я не знаю много о Eclipse. но я просто удалил копию файла банку из папки с библиотеками моего проекта, так что он будет использовать файл банку appcompat_v7 вместо этого. Эта фиксированная моя проблема .

4Elenasys @

Я пытался ответ, описанный здесь, но это это не распространяется работал для меня. У меня есть последние инструменты Android SDK версии . 23.0.2 и Android SDK Platform- инструменты вер . 20

Библиотека поддержки android-support-v4.jar вызывает этот конфликт, просто удалите библиотеку под /libs папку вашего проекта, Я не пугайтесь ,библиотека уже содержится в библиотеке appcompat_v7, чистый и построить ваш проект, и ваш проект будет работать как шарм !

Импорт android.support.v7 не может быть решен