После обновления - авария com.google.android.gms : плей- услуги: 5.2.8

? user3871754 @ | Original: StackOverFlow
---

мои зависимости:

compile "com.android.support:appcompat-v7:20.+"
compile 'com.google.android.gms:play-services:5.2.08'
compile 'com.android.support:support-v4:21.0.+'

но все же: Google Play услуги устарели. Требуется 5208000, но обнаружил, 5089036

как это возможно ?

UPDATE эту работу :

compile 'com.google.android.gms:play-services:5.0.89'

or

compile 'com.google.android.gms:play-services:6.1.11'

or

compile 'com.google.android.gms:play-services:6.+'

---

Top 5 ответ

1Michele @

Вы должны обновить Google Play Services из магазина Play на вашем устройстве, если вы не видите каких-либо обновлений, подождите, пока не выходит

https://play.google.com/store/apps/details?id=com.google.android.gms

Кроме того поиск по Google и установили новый АПК не используйте старую версию, как 5.0.77 или 5.0.89

2Jerome Campbell @

ИзменитьGoogle Play версии сервиса в build.gradle версии на вашем устройстве или эмуляторе .

compile 'com.google.android.gms:play-services:5.0.89' 
3josacky @

Версию вы ищете 5.2.08 .

Android Студия автоматически предложит обновить его до новой версии. Тем не менее, из-за ошибки, он падает начальный ноль в " 08 ", что означает замену зависимость с " 5.2.8 " вместо " 5.2.08 ", которая не работает. Чтобы это исправить, изменить зависимость читать " 5.2.08 " вместо " 5.2.8 "

This will work:

compile 'com.google.android.gms:play-services:5.2.08'

источник: http://tools.android.com/knownissues

4jQwierdy @

Для людей, которые страдают от этой проблемы, но не в состоянии сделать другую работу - моя проблема в том, что я установил Google Play 5.2.08 в моей Gradle файла (компиляция ' com.google.android.gms : Раунд плей- услуги: 5.2.08 '), потому что 5.0.77 не работает .

Я загрузил приложение на свой телефон, и он не работает,

Я имел последнее обновление (что я мог бы получить на моем телефоне - Android 4.4.2 ) из Google Play, так говорит мне, чтобы обновить не дать мне какие-либо опции

Я в конечном итоге просто необходимости обновить Gradle файл последней версии совместимого googlePlay, в моем случае версии 5.0.89 . Так выяснить, какая версия

5friederbluemle @

You can now use

compile 'com.google.android.gms:play-services:6.1.11'